Why doesn’t the hashtag work consistently?

AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
I know I’ve brought this up before, but now that the issues (if any) with moving the forums have been resolved, I’m wondering why the hashtag linking feature still doesn’t work consistently even in what looks to me like a simple situation (i.e. no confusing adjacent characters). For example, look at this thread: 
https://forum.brickset.com/discussion/28843/for-sale-us-used-star-wars-sets#latest
where it has created a link only 4 out of 25 times.

Comments

  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    Sorry if I’m being a nag @Huw; I brought this up on the Leaks thread too, but I was hoping the mix of working and non-working cases in the linked thread above would be helpful in debugging. 
  • Mr_CrossMr_Cross East Anglia (UK)Member Posts: 1,000
    I've had a few issues within PMs too. In the interests of information gathering I'll add a list of set numbers here and see what happens. #71043  #41629 #76051 #10721 #6869 #928 #70901 #21314 #10236
    some of these have worked in messages and some haven't. I haven't previewed this post fwiw.
    Astrobricks
  • Mr_CrossMr_Cross East Anglia (UK)Member Posts: 1,000
    Ah. Perhaps something is borken. #75060 I previewed this one, the link wasn't available before posting.
    Astrobricks
  • Mr_CrossMr_Cross East Anglia (UK)Member Posts: 1,000
    ^ I hope that helps in some way.
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    None of those work for me :(
  • oldtodd33oldtodd33 Denver 4800 miles to BillundMember Posts: 2,416
    #71043  #41629 #76051 #10721 #6869 #928 #70901 #21314 #10236. Just a test. I've never had a real set number not work for me.
    Astrobricks
  • oldtodd33oldtodd33 Denver 4800 miles to BillundMember Posts: 2,416
    edited August 2018
    #928 Odd they don't work at all. #75192. They don't seem to be working at all now.
    Astrobricks
  • Baby_YodaBaby_Yoda The world's backsideMember Posts: 1,228
    I haven't seen them work for a few days, actually...
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,441
    I'm not sure why, the code hasn't changed.
  • benbacardibenbacardi EnglandMember Posts: 367
    As far as I can tell, the Javascript only seems to search for the tags if they are already links:

    var patt1 = /^#[0-9]{1,}\-[0-9]{1,}$/
    $("a")
     .filter(function()
     {
     return patt1.test( $(this).text() );
     })
    ... etc ...
    

    My guess is that the forum software used to auto-link hashtags to the search functionality on the forum, and this extra javascript would hook into that and update the ones that match a couple of specific patterns to link directly to Brickset - and now, for some reason, the forum software isn't doing the auto-linking of hashtags (here's a #few #test #hashtags) and therefore @Huw's custom javascript can't work.

    Does the forum update itself or anything?


  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,441
    ^ Yes that is most likely the case, in which case it might spring into life if I adjust the regular expression. I'll have a play when I get a mo'.
  • benbacardibenbacardi EnglandMember Posts: 367
    ^ I'm not sure it will, because unless the forum is automatically creating links of all hashtags, the set hashtags still won't be links for your (updated or otherwise) regular expressions to be matched against!
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    Not sure if possibly related, but the color highlight of my own posts is also gone now. Doesn’t work in Safari on either my MacBook or my iPad. I don’t think it ever worked on my iPhone.
  • snowhitiesnowhitie BelgiumMember Posts: 2,853
    Wondering if you had a chance to play yet @Huw? It seems to coincide with the innability to send images in PM's too (as mentioned somewhere else), both things are sorely missed. Thanks.
    SeanTheCollectorAstrobricks
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    edited August 2018
    Not sure if possibly related, but the color highlight of my own posts is also gone now. Doesn’t work in Safari on either my MacBook or my iPad. I don’t think it ever worked on my iPhone.
    Others have also now reported this in the Brickset.com forum.
  • KeilupKeilup Frisco, TXMember Posts: 139
    I came searching for this issue.  I noticed none of the hashtag links showing in posts for several days now.  Was wondering if it was me or something else going on.  So seems to definitely not be working at the moment.
  • snowhitiesnowhitie BelgiumMember Posts: 2,853
    edited August 2018
    Also, when typing different paragraphs, there seem to be an extra line spacing come up, in PM but also noticed in messages on the thread. I can delete it in the edit but it's very strange. Doesn't always happen though but seems to get worse.
    Baby_Yodasid3windr
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    snowhitie said:
    Also, when typing different paragraphs, there seem to be an extra line spacing come up, in PM but also noticed in messages on the thread. I can delete it in the edit but it's very strange. Doesn't always happen though but seems to get worse.
    I think I’ve seen something like this. I’ll start typing and nothing shows up. So I tap in the edit box again (on iPad) and then it starts working. I’m sure this extra step is new, but it doesn’t happen every time.
    Mr_Cross
  • snowhitiesnowhitie BelgiumMember Posts: 2,853
    edited August 2018
    Actually, in PM's it's even affected old PM's. Something that looked like this:
    blablabblablab
    jadajadajada
    blabalbalbab
    now looks like this:

    blablabblablab

    jadajadajada

    blabalbalbab
    Like there is extra lines in there now.
  • datsunrobbiedatsunrobbie West Haven , CTMember Posts: 1,459
    ^I know next to nothing about HTML formatting, but when my Synergy/DBL reports misbehave like that it is usually text wrapping because the margins of my display area are not as wide as the text being displayed. 
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,441
    If someone cleverer at JS than I can rewrite this code to change #xxxxx to a hyperlink  rather than hyperlinks that have already been created on #xxxxx then I'll plug it in:

    <script type="text/javascript">
    $(document).ready(function() {
    var patt1 = /^#[0-9]{1,}\-[0-9]{1,}$/
    $("a")
    .filter(function()
    {
    return patt1.test( $(this).text() );
    })
    .each(function()
    snowhitie
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,441
    It's working again. Apparently hashtags were disabled in the the new forum code by default.
    PaperballparkmadforLEGOgmonkey76AstrobrickssnowhitieBumblepantssid3windr
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    edited August 2018
    Thanks @Huw
    Any ideas about the lack of blue shading for one’s own posts, or the problems with pics in PMs?

    I know, I know, we’re never satisfied :)
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    edited August 2018
    oldtodd33 said:
    #71043  #41629 #76051 #10721 #6869 #928 #70901 #21314 #10236. Just a test. I've never had a real set number not work for me.
    Weird that the second one above still doesn’t work. But it does here #41629 . Hidden adjacent characters?
  • AleyditaAleydita BelgiumMember Posts: 794
    oldtodd33 said:
    #71043  #41629 #76051 #10721 #6869 #928 #70901 #21314 #10236. Just a test. I've never had a real set number not work for me.
    Weird that the second one above still doesn’t work. But it does here #41629 . Hidden adjacent characters?
    Looks like a preceding double space.
    Baby_YodaAstrobricks
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,468
    edited August 2018
    Testing preceding double space  #41629  #41629  #41629 .
    Sure enough. That seems to break it.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,441
    edited August 2018
    That's because double space can't exist in HTML so the second one is replaced by a & nbsp; a non breaking space which isn't matched by the regular expression.
  • CCCCCC UKMember Posts: 17,799
    edited August 2018
    #41629 #41629  #41629   #41629    #41629


  • CCCCCC UKMember Posts: 17,799
    edited August 2018
    #9489  #9490  #9491  #9492  #9493 (2 spaces)
    #9489   #9490   #9491   #9492   #9493 (3 spaces)
    #9489    #9490    #9491    #9492    #9493 (4 spaces)

    Weird.
    gmonkey76SprinkleOtter
Sign In or Register to comment.
Recent discussions Categories Privacy Policy