Shopping at LEGO or Amazon?
Please use our links: LEGO.comAmazon
As an Amazon Associate we earn from qualifying purchases.

myBrickset Android App



  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Aw shucks, you'll make me blush :) Glad you like the app, I don't MOC etc so it's just my way of giving back to the community and (hopefully) helping drive more people to

    The app's free because I don't feel right charging for something where I'm just an intermediary to brickset's data, and I hate ads (especially in apps) which is why there'll never be any! So my payback is in feedback and gratitude from end users such as yourself, and it's highly appreciated - thanks :)
  • LegoboyLegoboy 100km furtherMember Posts: 8,831
    And your efforts are very much appreciated by many of us, thank you.

    Having trouble again Rik. Installed the app. I click on the Logs icon and get the following error (screenshot). I clear the error and enter 'mybrickset' into the filter. Good. I click the refresh button and get the same error message. Having cleared it again I click send data and nothing happens. In an attempt to save the data and send the file direct, I get the same error.

    I don't think there's anything wrong with my phone as I don't have any problems elsewhere, but I guess it's possible.

  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Thanks for the attempt, I've never seen Elixir do that before but it's not my app so there's not much I can suggest. Don't worry about it, I'm going to go over the db upgrade code line by line, see if there's anywhere it could possibly fail and add a lot more logging so I can debug just in case. I've also recently added code that checks the db has the expected columns before the app starts - I used to have this but pulled it all out when I rewrote the upgrade code in (I thought at the time) a way it would never fail. That will at least stop the app crashing when it can't find a column (and is less overhead than filling the code full of try/catch blocks every time I access the db).

    Maybe I'll investigate writing a quick app that automatically collects and mails the myBrickset log too, that'll be a lot easier for people to use than Elixir.

    Thanks guys, hopefully I'll have another rc by the end of the week or Sunday evening if my day job gets in the way!
  • LegoboyLegoboy 100km furtherMember Posts: 8,831
    It did occur to me just now that maybe the antivirus was playing havoc with Elixir but no, having disabled it and tried again, failed. Sorry.

    Something else for the wishlist, depending on the effort involved. :o)

    Once viewing a set, say #7595, Army Men on Patrol, Toy Story. It would be really handy if once within a set you could click 'Toy Story' and all of the sets within that theme or sub-theme could be listed. Saves having to come out and browsing to another set.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    How could I say no to you? :) I can see that being tricky to use for cell phones (especially when Theme and SubTheme are both shown) but useful on tablets. The easiest way to code would be that pressing Toy Story would take you to the Search Results, then 'back' would take you back to #7595 (rather than the Main Screen). I'll look at adding a link to the app icon so it'll jump straight to the Main Screen. If this turns out to be trickier than thought I'd leave it for the next version.

    Related to that I've been wanting to implement full browse functionality too (rather than just search) especially now I've started adding tablet stuff. I'm sure I'll get a round tuit eventually (I'm also playing with coding a web site from the ground up in my spare time, so myBrickset is fighting for attention!).
  • LegoboyLegoboy 100km furtherMember Posts: 8,831

    I can see it being tricky to implement. given how it's currently structured. I think it is because I use the function so regularly to view more of a theme in the main site. It really isn't a biggie. Was just a thought. :-)

    myBrickset is fine the way it is. You get on to your other project. :-)
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    @Legoboy - I never listen, just ask my S.O. :)

    So, here's rc3 (41.7MB) - it's more quick 'n dirty than my usual rc's, but has the new Theme Search functionality.

    I was going to implement Theme & Subtheme separately but the app's not currently set up for that - I can do it though if you'd prefer. When you click the theme, the app does a search for the specified theme (& subtheme, if any) then shows the results as normal.

    It also has 'home' functionality on the menubar icon for Search & Set Detail (I'll add other screens later). This allows you to quickly return to the Main Screen rather than hitting 'back' multiple times.

    My ftp upload's taking a while, the app should be available within 10 mins (20 max) of my hitting submit here - so about 11:30 EST, 04:30 GMT.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    OK, barring any unforeseen issues this should be the last 1.8 rc (41.9MB). I've fixed the issue with the db not upgrading (turns out it was upgrading, but one of the sanity checks I recently added wasn't all that sane..) and made the grid & list entries a little larger on tablets.

    There's a new requested feature which added an icon on the results page to cycle between all results, owned, wanted, owned & wanted then back to all.

    And some minor tweaks such as using much less memory when rendering images (especially important for grid mode) and always rendering images on a background thread (should give slightly improved performance).

    I'll update the db and images to the latest copy when I do the actual release, but the functionality will not be changing unless any bugs crop up.
  • JosephJoseph Member Posts: 651
    Works great on my phone, the only bug I can find is that the "both owned and wanted" filter always turns up no results.
    Incidentally, I just decided to give it a try on a tablet I had lying around and it gives me the database error every time. It's an hp touchpad repuposed for Android though so maybe it will work fine on more "normal" tablets.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Thanks for testing (again!) Joseph.

    It's a bit worrisome that you got the db error (presumably the one saying 'please retry or reinstall'), I've gone through the code again and don't see any errors. Is it a device that you've upgraded the app on or is it the first time you've installed the app? If it's the first time, maybe there's some permission issues with installing the db. Could you try using Elixir to get the log files like I mentioned a few posts back? (hopefully it'll work, recent Android versions totally lock down the logs to anything other than the relevant process).

    The 'owned & wanted' is AND rather than OR, so will only show sets that are both owned and wanted (eg, I have the Panda Guy CMF but also want to get more). OR would maybe have made more sense, but the code isn't set up to allow that yet. It should give the exact same results as if you'd ticked both boxes on the search screen.
  • JosephJoseph Member Posts: 651
    edited January 2014
    Well, you can disregard the log file I just sent you since I figured it out. Apparently the rom I was using had multiple "users" enabled but only gave one of them complete functionality. It opens fine when I switch back to the primary account. (sorry about the false alarm)

    I see, I thought the owned and wanted was simply a combination of the previous two. It makes sense once you explain it.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Thanks for taking the effort to get the log files, and I'm glad you were able to figure it out (and doubly glad it wasn't anything on my end!).

    I can see "owned [logical or] wanted" being more useful than "owner [logical and] wanted", I might have to see if I can improve this in a future release. Or maybe just remove the option entirely in this release if it's confusing (so cycling between "all", "owned" and "wanted" instead).
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Good news everyone!

    myBrickset 1.8.0 is now out on Google Play & Amazon App Store. Check it out and let me know what you think!
  • LegoboyLegoboy 100km furtherMember Posts: 8,831
    Updating as we speak. Thanks.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Following brickset's server move there's an issue communicating with which means it's not currently possible to log in (if you're already logged in, don't log out!) or sync changes. I hope to get a fix out tonight (once I get home from work and have looked into the issue).
  • staffmarkstaffmark Member Posts: 44
    As of the last several days, I notice that the "wanted list" goes blank every time I restart the app; i.e., there' s nothing in my wanted list. I can re-fill my wanted list, and the changes will stick, but only until I get out of the app; once I get back in the changes are lost and the wanted list is again blank. Just FYI.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    I'm guessing it's related to trying to sync with brickset and not being able to get a response, but it's very odd that it would clear the list. I'll take a look, thanks for the info.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    @staffmark - issue should be resolved in the next version (1.8.1). You shouldn't have lost any data as Brickset maintains the master list - the next time you sync (which requires the next version anyway) the app will download all of your owned & wanted sets. There's a bug in the current version where if the sync fails then it thinks you don't have any (oops).
    If you want to be absolutely certain you don't lose anything, you can clear the app's data or uninstall & reinstall before syncing.

    1.8.1 should be out shortly and will resolve the login & sync issues for everyone, just doing some final testing.
  • IanAIanA Wakefield, UKMember Posts: 2
    Hi, yesterday I joined Brickset and setup my owned sets. I then downloaded the app on two devices. Both devices failed to sync (followed all procedures to force a manual sync) but this was expected given the note published on Google Play about the change of server breaking the sync.

    Today I updated myBrickset to V1.8.1 and this has not cured anything. I know a bit about Android development so used Eclipse's LogCat to look for any errors or warnings. Sure enough every time I try to sync I get the same SOAP error (on both devices): android.sax.BadXmlException: Line 2: Root element name does not match. Expected: '', Got: ''

    Looks like a simple type namespace mismatch to me. I would expect all versions of the app to be having this problem but maybe it has not been noticed yet as the app appears to do a 'sets changed since xyz' request that for many people simply won't return any results - but I'm guessing here.

    I can of course send you more verbose LogCat exports if required and on a more positive note, bar this sync issue, it is a very good app - love the bar code lookup.
  • IanAIanA Wakefield, UKMember Posts: 2
    To save time here is the log for a failed sync - app starting from cold after cleared data.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    edited February 2014
    Thanks for the info @IanA, it's certainly useful and a nice change to get a detailed error report! It looks like Huw updated (corrected) the namespace this morning so I'll need to issue another build to fix sync again. I'll update the notes on Google Play to reflect the current situation.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    edited February 2014
    I'm currently pushing 1.8.2 out to Google Play which resolves the issue and enables sync again, thanks everyone for putting up with the delay whilst I got things sorted.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    edited March 2014
    Given the number & nature of changes in the upcoming version of myBrickset, I've taken the unusual step of publishing a separate app which will act as a public beta.

    If you'd like to try out the new features, you can grab a copy from Please be sure to let me know what you think. Bugs can be logged here, by PM, by email, or on the new bug tracker I've just installed at

    Be careful if updating data in both myBrickset and myBricksetBeta at the same time - if you enter different values in both apps, there's no guarantees which values will be kept!

    Some of the new functionality included is:
    • Faster sync - thanks to the new brickset api, less data is transferred during the sync process. This results in a faster sync times with less bandwidth usage. Also reworked the sync code to reduce the number of database accesses, resulting in faster sync times.
    • More intelligent sync - can now handle when data is changed on both & myBrickset at the same time (tho' if a field is changed in both places, the value in myBrickset will be used).
    • Smaller app footprint (approx 50MB down to approx 8MB) - will allow faster updates and allow minor fixes to be pushed without requiring 50MB downloads.
    • Better quality images - images are now twice as large, so will appear sharper and more detailed. Will be especially noticeable on tablets.
    • Additional images - "Additional image"s can be viewed by clicking on a set's main image and then swiping left and right. myBrickset ships with low res images, higher quality will download on demand (and of course be cached locally) if there's an active internet connection.
    • EU Prices - EU (German) prices are now included where available.
    • ACM integration - coming soon (will be read-only initially).
    When you first download the app, there will be a one-off additional download of appox 200MB (this includes all of the high quality thumbnails). This will be performed automatically by the Play Store, if it's interrupted then myBricksetBeta will resume it when launched.

    Please let me know what you think, and what changes or new features you'd like to see (non-CMF minifigures are not currently possibly to be included, unless anyone can provide me a source for images & data).

    If you use ACM a lot, please let me know as I'll be interested in your input on how you'd like ACM integration in myBrickset and whether read-only data is of any use.

    If you are fluent in a language other than English and are willing to translate the app in exchange for your name appearing in the app's About page, please let me know!
  • JosephJoseph Member Posts: 651
    edited March 2014
    Just a heads up, zooming in on pictures doesn't work in this beta version.
    That ACM integration could definitely come in handy though, especially considering how it doesn't currently work on many mobile/tablet size screens.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Probably broke that yesterday when I was adding in support for the additional images (both rely on touch input, so there's likely a conflict between them). Will take a look tonight, thanks for the bug report :)
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Beta 1.9.3 has been pushed out, it includes a couple of small fixes and the initial implementation of ACM (currently on the menu on the Set screen, and I haven't investigated what it looks like on tablets yet).

    As usual, any feedback is appreciated :)
  • JosephJoseph Member Posts: 651
    edited March 2014
    A few bugs I've run into while testing it on my nexus 7:
    - If I tap on more than one set entry in landscape it force-closes, whether it's double-taping on same entry, selecting a different one after the first, or trying to scroll after selecting one.
    - If I select a set in landscape and then change the orientation (either landscape to portrite or back again), it says loading indefinitely (until I press the back button or tap the screen). After I do that, it gives "filler" set info in landscape until I re-select the set. Example:image
    - Taping on any picture (aside from those from White Fang's reviews) causes a force-close.
    - Sometimes after selecting a set in landscape, there are two help buttons instead of a help button and a "menue overflow" button. It only seems to happen if you go to the list of sets in portrait, switch to landscape, and then select the set. Ex: image
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Thanks for the feeback Joseph. Can't recreate any of those issues with my S3 in landscape, I'll try on the tablet tomorrow night (will admit I haven't done any tablet testing yet for the beta builds, all my dev work has been on the S3).
    The two Help icons is caused by the app displaying help for both the list view and the set view at the same time. I'm not sure what to do about that, maybe remove help for the list view as soon as the set view is activated?
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Sorry for that, it was caused by some performance enhancements I did that I hadn't tested on the tablet - had to make a small change so it would work with multiple active fragments. Fix has been uploaded and will be available soon hopefully.

    I'm seeing an issue with high res images for "additional images" not always downloading, so I'll investigate that. ACM works but needs a more optimised layout for tablets.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Two years, ago myBrickset was released and marked the first Android app with Brickset integration. myBrickset remains the only app with a full offline auto-updating copy of the database & images, and as always is free, ad-free and referral-free.

    Version 2.0 has been reworked to integrate with the new Brickset API v2, giving faster synchronisations with less bandwidth usage.

    Two new features have been introduced:
    * view additional images (select a set's primary image, then swipe left & right)
    * ACM integration - view your ACM data (read only)

    In addition to this all images are now 2 times their original size, so will appear sharper and more detailed - this is especially noticeable on tablets.
    To support this, images are now a once-only download, with new images being added with each new release. This gives an initial download size of approx 200MB, but updates will be about 8-10MB (rather than 50MB with current size images).

    Where available, prices may now be displayed in Euros (this was a much requested option but was not possible until now).

    If you haven't left a review yet on Google Play, please do so! And if you haven't installed the app on your kid's / spouse's / co-worker's device, what's keeping you? :)

    Thanks to everyone who takes the time to leave a review, email me with feedback, helps diagnose crashes, etc.

    Special thanks as always to @Huw for his work behind the scenes and putting up with my incessant emails and change requests!

    myBrickset 2.0 is available now on Google Play. It's a staged roll-out so may not be available immediately to everyone but should be there by the end of the week.

  • JosephJoseph Member Posts: 651
    One bug I'm encountering with the new update: If I view a set in landscape mode (on a tablet) and then switch to portrait, I can tap on sets but all it does is change the name at the top, as opposed to switching to the set page. If I then go back to the main menu and try again, I get a force-close when tapping on the set.
    Anyway, just a very minor bug; thanks as always for this wonderful app (which, for the record, is at least 3 times better than any "competitors" ).
  • timinchicagotiminchicago USAMember Posts: 239
    @RikTheVeggie any chance there will be a Windows Phone version?
  • LegoboyLegoboy 100km furtherMember Posts: 8,831
    Am very grateful for your efforts Rik. One of the few apps that worthwhile downloading. :-)

    Am trouble with the new version however in terms of the 'account switching'. I try to with and it just freezes. I have tried uninstalling and starting again (fixed the issue on a previous release), but no luck this time. Just a minor bug but thought you should know. J.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    How come these bugs never surface during betas but always appear as soon as I hit "ship" on the release version? :)

    @Joseph - you're in danger of being promoted to head of QA soon! It doesn't sound like a tricky one to fix so hopefully I'll be able to do it over the weekend.

    @Legoboy - I've managed to recreate this on my cell phone. I'll get this fixed asap, not sure what's wrong but it can't be anything major and will probably be easier than the rotation issue actually.

    @timinchicago‌ - Sorry, I'd have to say the chance of a WinPhone port is very slim - the app is Android native so would need a complete rewrite. There are a few relevant apps listed in the Mobile Apps Directory, Brick Manager looks quite nice actually but appears to be online only.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Got home a few mins ago and took a look - both issues were really simple to fix so I'll get an update out later today. Thanks for the bug reports, keep them coming!
  • bnlmaikebnlmaike Member Posts: 2
    Thanks for a spectacular app, I am however having a bit of trouble, not sure if it's Samsung related as I cannot get minifigure list to populate on either my Note3 or Galaxy Tab10.1, sets owned and wanted appear promptly but Minifigures say no results found, not sure if I overlooked something but I read back a ways here and didn't see mention of it. Also have uninstalled and reinstalled app on both devices.
    Thanks again...Bryan
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    @bnlmaike - if you select "Show All" for minifigures do you get any results? I'm guessing you're expecting "standard" minifigs to show, unfortunately myBrickset currently only handles CMFs. This is due to copyright restrictions over images, I have not been able to find anywhere willing to allow me to use their images in the app.
  • bnlmaikebnlmaike Member Posts: 2
    RikTheVeggie -
    Thanks for the response, when selecting "all" the minifigures do show, I guess I was expecting the"owned" and "wanted" to sync with website as it did with the sets. If I go through and manually select the minifigures they will show in the "owned" tab, was just hoping to avoid the manual entry of hundreds of minifigures from sets and loose as it is already done on the brickset site. Thanks for the time
  • Iancody2010Iancody2010 Member Posts: 2
    Can you get it on kindle fire?
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    @bnlmaike‌ - CMFs which are "sets" will sync (eg, but CMFs which are "minifigs" will not (eg, All other minifigs are not currently handled.

    @Iancody2010 - myBrickset is available in the Amazon App Store, it can also be "side-loaded" if you have the apk from another device.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    It's been a while since I've posted, but as a heads-up version 2.1.0 is now rolling out. This is mostly a bugfix release, the biggest fix is for an annoying bug which stopped sets showing up when searching by theme. All recent data & images have of course been added too for offline browsing / to save your data allowance. CMF 'parts' images have been added for CMF 12, to help find specific CMFs in-store.

    I'm still hunting around for a source of royalty free minifig images (unfortunately most of the ones used by are under a licence which I have been unable to obtain), please let me know if you know of any.

    myBrickset is now available for the first time on Fire Phone & HDX - if you have one of these devices, please let me know if there are any issues!
  • blake711blake711 Member Posts: 23
    On my android tablet and phone. mybrickset has pulled in all my sets but not my collectible minifgures. I can add a collectible minifigure on mybrickset and it will show up as owned on mybrickset but it doesn't change on Any ideas?
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    myBrickset handles CMFs as Sets rather than Minifigures, so if you mark 71008-14 as owned on the app it will show up as owned when you search for this as a set on (
  • Sir CSir C Member Posts: 2
    Series 12 shows as miscellaneous so is not listed in minifigures category, what can I do to fix this?
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    That's unexpected, CMF S12 is displaying fine here and I can search for them by specifying Theme = CMF (in fact it wouldn't even display in Search if it was set incorrectly).

    If your data is synced with you could try reinstalling or just going to App Settings and hit 'clear data' - this will cause the app to redownload everything and hopefully get the correct data for you. Unfortunately this will lose anything that isn't stored on the Brickset servers, such as 'favourite', 'built' & 'gift'.

    If you'd rather not do this, please email me (details are on the Play Store listing) and I might be able to provide you with an alternative solution (but I need to go home and research it, I'm at work atm)
  • Sir CSir C Member Posts: 2
    Clearing app data fixed the issue, thanks!
    Best aplication for lego tracking by the way, keep the great work!
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Glad that worked :) All I can think is the CMFs were added as "Misc" initially in, then they were corrected manually which didn't trigger an update to be sent down. Normally I release a new version of the app (with an up to date copy of Brickset's database) frequently enough that this isn't a problem, but updates have been slow lately as my day job's been taking up more & more of my evenings! I'll have a think about if there's anything I can do to stop this happening in the future, or at least mitigate the impact.

    Glad you like the app, it always surprises me how popular a little thing I wrote for myself has become! With luck it'll become the official unofficial Brickset app for Android :) [once I figure out support for minifigs]
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Is anyone with access to a device with Lollipop installed willing to test something for me? It would involve deleting some files from /data/obb (will provide exact details when required) and launching the current app. This will result in an error I think (I'm going from crash logs on Google Play, they don't provide many details), then I have a new app that can be sideloaded which should work and re-download the required data from the Google servers.
  • iamterryiamterry Member Posts: 163

    Is anyone with access to a device with Lollipop installed willing to test something for me? It would involve deleting some files from /data/obb (will provide exact details when required) and launching the current app. This will result in an error I think (I'm going from crash logs on Google Play, they don't provide many details), then I have a new app that can be sideloaded which should work and re-download the required data from the Google servers.

    I've not got it installed any more so more than happy to try a test version. I'm running 5.0.1.
  • RikTheVeggieRikTheVeggie CanadaMember Posts: 353
    Thanks @iamterry, PM sent.
Sign In or Register to comment.

Shopping at or Amazon?

Please use our links: Amazon

Recent discussions Categories Privacy Policy

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started. is a participant in the Amazon Services LLC Associates Program, the, Inc. Associates Program and the Amazon EU Associates Programme, which are affiliate advertising programs designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.

As an Amazon Associate we earn from qualifying purchases.