Shopping at LEGO or Amazon?
Please use our links: LEGO.comAmazon
As an Amazon Associate we earn from qualifying purchases.

Forced to use a previous version of Digital Designer

knuclear200xknuclear200x Member Posts: 45
edited April 2011 in Building and Techniques
Every time I open version 4 on my Dell Windows 7, the program closes in one second. I realize it is because I dont have the required graphics card: NVIDIA GeForce 5200/ATI Radeon 7500 or better

Although I love that this version still has the ball/joint brick and T-Piece, I discovered that 4.0 has a Hero Factory section, a feature on which i intend to...go crazy, which is why I'm posting this now.

The Extended/Universe mode doesn't seem to work because an old version can't be online, so is there some extension pack i have to download to get certain pieces or is it all powered by being online? Any alternatives?

Comments

  • MatthewMatthew Cheshire, UKAdministrator Posts: 3,735
    Sorry, I don't know about LDD, but isn't there an online interface for HF?
  • vynsanevynsane Member Posts: 179
    edited May 2011
    Hi, knuclear200x - it's possible that you have 'high quality brick rendering' and 'outline bricks' set to 'yes' in your preferences.ini file associated with LDD. The solution to this is:
    Turn advanced graphics OFF (because LDD is crashing or not starting)
    Q1: I just installed/updated LDD over a previous version, and now LDD will only start for a few seconds and then shut down or will not show up on screen.
    A: It may be because you have a line in your preferences.ini-file left from a previous LDD installation that says

    UseShadersInScene=yes
    UseShadersInPalette=yes

    and with the latest versin of LDD your graphics card cannot handle this. So you need to edit the preferences.ini-file and set those values to "no".
    For Windows 7 and Vista it can be found here C:\Users\UserName\AppData\Roaming\LEGO Company\LEGO Digital Designer\preferences.ini
    For Windows XP here: C:\Documents And Settings\UserName\ApplicationData\Lego Company\Lego Digital Designer\preferences.ini
    NOTE: If you can't find this folder, the read here how to make it visible

    If the above doesn't solve the problem, try this:
    1) Exit LDD if it is running and make sure that all instances of LDD are closed (Open Start Task Manager and look at the Processes folder. Close any processes called LDD.exe).
    2) Now uninstall LDD, and then delete all LDD files in two places:
    a) The above folder (....UserName\ApplicationData\Lego Company\Lego Digital Designer\)
    b) "C:\Program Files\Lego Company\Lego Digital Designer" (or "C:\Program Files (x86) \Lego Company\Lego Digital Designer" for Windows 64 bit editions
    4) Re-install LDD and start.
    6) Still doesn't work? Exit LDD and again edit/add the preferences.ini with UseShadersInScene=no and UseShadersInPalette=yes
    5) Still doesn't work? Exit LDD, edit the above mentioned preferences.ini and add CompatibilityModeLevel=100, then re-start LDD.
    This is taken from a topic at Eurobricks about LDD troubleshooting.
  • vynsanevynsane Member Posts: 179
    knuclear200x - did you ever get a chance to check out these steps? I noticed this topic didn't filter to the top of the main page when I previously posted, so I'm bumping this in hopes that you see it.
Sign In or Register to comment.

Shopping at LEGO.com or Amazon?

Please use our links: LEGO.com Amazon

Recent discussions Categories Privacy Policy Brickset.com

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Brickset.com is a participant in the Amazon Services LLC Associates Program, the Amazon.com.ca, Inc. Associates Program and the Amazon EU Associates Programme, which are affiliate advertising programs designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.

As an Amazon Associate we earn from qualifying purchases.