Shopping at LEGO or Amazon?
Please use our links: LEGO.comAmazon
As an Amazon Associate we earn from qualifying purchases.

42083 - Post Build

Just finished the set, took around 3 weeks on and off, including waiting for a missing part (which came pretty quickly).

I noticed that the set appears "flimsy" with things like the wheels popping off, the front moving about and there are 2 blue parts which seem to move freely at the front of the model (I may have forgotten to clip them somehow.

one thing I am disappointed about is the engine is no longer "moving" (the yellow bits).  How easy is it to get this going again?

Comments

  • MaffyDMaffyD West YorkshireMember Posts: 2,822
    The wheels shouldn't easily pop off, and I doubt any part of a Technic design is intended to be flimsy or stop working, so I can only presume (I haven't built mine yet and I wouldn't hold your breath for that to happen) that there's been a step or two missed in the instructions, although seeing as you've finished it it might be hard to fix without a total rebuild. Some photos might help and then maybe some Technic people who HAVE built the Chiron could comment...
Sign In or Register to comment.

Shopping at LEGO.com or Amazon?

Please use our links: LEGO.com Amazon

Recent discussions Categories Privacy Policy Brickset.com

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Brickset.com is a participant in the Amazon Services LLC Associates Program, the Amazon.com.ca, Inc. Associates Program and the Amazon EU Associates Programme, which are affiliate advertising programs designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.

As an Amazon Associate we earn from qualifying purchases.