Please refrain from posting animated GIFs, memes, joke videos and so on in discussions other than those in the off topic area.

Dismiss this message to confirm your acceptance of this additional forum term of use.

Problem redeeming VIP points

wildcatwildcat LouisianaMember Posts: 5

Has anyone had recent problems in the LEGO online store with redeeming your VIP points?  It shows that I have up to $15 to redeem, but it will not actually let me select anything in the drop-down box.  My purchase is in the $150 range, so that shouldn't be an issue. I have tried IE, Chrome, and Firefox, and several different computers/devices.  None of them have worked.

I just thought maybe someone here knew of a solution or suggestion as to what I am doing wrong.

Thanks!

Wildcat

Comments

  • akunthitaakunthita USAMember Posts: 1,026

    I just placed an order recently and didn't run into any issues. The little box was there to redeem my points, I selected the amount, and that was that. If you tried out three different browsers, they may have a temporary glitch on their end. You can try later, or you can call customer service to let them figure it out for you.

    You can also place your order while on the phone, and they can help you redeem your VIP points. Calling customer service is usually the best way to deal with situations like this. They are super helpful and can take care of issues much quicker and more directly. Brickset members may or may not have dealt with issues like this, and even if some of us did, our issue may or may not be related to the issue you are facing. So I would suggest giving LEGO a call.   

    gmonkey76
  • obi_gobi_g BlightyMember Posts: 500
    i had a similar problem. it turns out that when i had my vip card replaced (and got a new number) the old one was still showing up. i had to contact lego customer services and they sorted it out and now i can redeem points again. good luck :)
  • jonboy2000jonboy2000 Member Posts: 222
    Logged into my VIP account today (first time in ages) and it says you now have to earn 800 points to get a £5 voucher.  As far as I recall it's always been 100 points for a £5 voucher.
    So has my points balance seriously devalued?  I was going to talk to CS but no one there today.
    Sorry I thought there was a thread on the new VIP system but can't seem to find anything.
  • AstrobricksAstrobricks Minnesota, USMember Posts: 2,424
    Logged into my VIP account today (first time in ages) and it says you now have to earn 800 points to get a £5 voucher.  As far as I recall it's always been 100 points for a £5 voucher.
    So has my points balance seriously devalued?  I was going to talk to CS but no one there today.
    Sorry I thought there was a thread on the new VIP system but can't seem to find anything.
    Enjoy:
    https://forum.brickset.com/discussion/30448/what-has-happened-to-vip-lost-my-cash-and-cant-re-sign-up-to-vip-as-my-email-already-exists#latest
    560HeliportBaby_Yoda
  • jonboy2000jonboy2000 Member Posts: 222
    @Astrobricks ; Thanks for that.... Bunch of #%^@$
    Astrobricks
  • KingAlanIKingAlanI Rochester, NYMember Posts: 1,869
    The points accumulate quicker now so 5 vouchers costing more points should be equivalent
    My problem a few weeks ago was point usagd taking me below promo threshhold and that hadn't counted against me before
Sign In or Register to comment.
Recent discussions Categories Privacy Policy