The forum is now at http://forum.brickset.com. Please update your bookmarks.
Please refrain from posting animated GIFs, memes, joke videos and so on in discussions other than those in the off topic area.

Dismiss this message to confirm your acceptance of this additional forum term of use.
You must be 16 or over to participate in the Brickset Forum. Please read the announcements and rules before you join.

Problem with information flow between Rebrickable and brickset database

Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
@huw

Whilst logged in just now and looking at a set I don't own (#10196) the Rebrickable box said that there was no data available for this set at Rebrickable.

After I got over the sheer panic as this is not a new set that the data isn't available for yet :o) I logged into rebrickable and found that my beloved set details were in fact available as they have been on many previous visits. Phew!

I had a look at neighbouring sets in the database that I also don't own (#10198 and #10200) and found they too were displaying the same no data available at Rebrickable message.

Of course I know sets I own don't show the rebrickable box. Only sets I don't own usually show the percentage of parts owned in my collection for a set where rebrickable has the set info. 

I find this a most useful feature of the database (means I stay on brickset unless I need a rebrickable specific feature) and I know it was working before but I'm not sure when I used it last successfully, a few weeks ago, maybe? I appreciate it may be due to a change at Rebrickable's end and or a change at brickset. 

Comments

  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,245
    Nowt has changed at this end and I'm away atm so can't investigate fully. I will if it's not working when I return. 
    Lego_Star
  • Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
    Figured it was more likely that Rebrickable had made a change. Cheers Huw. 
  • Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
    Sure you are very busy since you are not long back @Huw and with bricktastic next weekend, but just a gentle reminder this is still not working.
  • Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
    Can this be fixed easily? Really miss being able to see this at a glance when I visit set detail pages.
  • Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
    edited September 11
    @huw
    I noticed this weekend that rebrickable thought I still owned a set I removed from my collection on brickset weeks ago. So now it seems the synchronisation of collection data between it and brickset is also no longer working. Set is #76077
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,245
    edited September 12
    I've just tested this out and it's adding and removing sets at Rebrickable when I add and remove them here OK.

    Might be worth re-validating your RB login details in your profile at Brickset  and doing a manual sync at https://brickset.com/export/rebrickable
    Lego_Star
  • Lego_StarLego_Star ... in a galaxy far, far away.Member Posts: 1,763
    I tried this ^ last month and this was what happened. This thread can now be closed.


    Something was still up.

    I went to the link ^  first, last send to rebrickable was in 2015. I sent to rebrickable to be told no sets added.

    I then went to my brickset profile and found the rebrickable username was my email address, not my user name and so amended the username to be my rebrickable username (though I know the email address is also correct for the login, I just prefer to use the username). Checked the login details - confirmed correct. I sent again. Brickset host fell over (I got that browser cloudflare brickset screen).

    I waited a few minutes and tried again. It took longer this time but still came back with the no sets added message.

    Weirdly, brickset is now showing the % of set owned info again on the set page (but #76077 100% though not owned!?) that I originally found wasn't working when I opened this thread BUT rebrickable still thinks I own #76077 - 100% of the parts.

    In my brickset collection, I don't own the set. So parts like Coulson minifig are only in that one set. I don't own Coulson and my rebrickable preferences are set to include figs not ignore them. I also found a constraction part in that set that I also don't own - 90641 in white. It's weird. Brickset says I own all of the exact parts. Rebrickable shows me the sets to build from and of course #76077 is shown first because rebrickable thinks I own all of the parts.

    So I tried clicking on "own" in brickset and changing the number to 0 and resent, same result.

    Last I tried adding the set again to brickset, but I stopped what I was doing in the middle to eat my dinner and came back a little later, to find I was logged out of brickset. Logged back in, removed the set and finally all was right with the world.

    At last brickset acknowledges I don't own the set whilst 96% owned is displayed on the set page. The constraction part I mentioned page was still open in rebrickable, only now I own it only in black not white, which is correct, and on rebrickable I own 96% of the set. Yay, so glad it's rectified. Somehow being logged out of the brickset made the difference. Which is again weird because the data is uptodate right away normally once changes are made.

    I very rarely remove an owned set but #76077 was one I bought for half price but then decided to return and refund.

    It's all very strange but delighted it's back to working as expected. Thanks @Huw.
    Huw
This discussion has been closed.
Recent discussions Categories Privacy Policy