Please refrain from posting animated GIFs, memes, joke videos and so on in discussions other than those in the off topic area.

Dismiss this message to confirm your acceptance of this additional forum term of use.

The new Brickset: known issues

HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
edited February 2014 in Brickset.com
I'll use this thread to provide information on bugs and problems with the main site:

Sign-up and password reset emails not being received

For a short time earlier in the week, the mail server that Brickset.com emails are sent from was blacklisted for spam. That has been resolved and as far as I can tell emails are now getting through.

Country detection

A new method of country detection has been implemented which should now show your country correctly.

Keep having to log in

I've added some code which should ensure the authentication cookie used for sign-in is persistent and thus prevent this.

Adding/Editing comments

If you edit a comment then press save the comment is not shown however the changes have been saved. This appears to be a CloudFlare related problem because when I bypass it it works fine. I don't know if I'll be able to fix it but I'll give it a go.

When you add a comment it's possible that the timestamp shown will be in UK time, not your local time, but will show correctly when you refresh the page.

Breadcrumbs on set details pages

The last breadcrumb can show the 'wrong' thing in some circumstances. It's supposed to provide a link back to the list you've been viewing but if you have two tabs open is gets confused.

Amazon price comparison page

This is working OK but many of you miss some of the features of the old site. I will give it some attention next week.

Import from Rebrickable and Lugnet

These are now working.


«1

Comments

  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    Country detection:

    Some people who used the new site when it first went live may have their 'preferred country' set to Europe. I've just uploaded an EU flag so that this is more obvious which will now appear top-right.

    I'll upload new code later in the week which will reset everyone's preferred country to their actual one, which will iron out this issue.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    Keep having to log in:

    This is causing a few headaches because it seems the cookie is present but is being ignored for some reason. I've made a configuration change this morning which might make a difference: let me know.
  • legomattlegomatt Member Posts: 2,541
    edited February 2014
    Huw said:

    it seems the cookie is present but is being ignored for some reason.

    We can rule this out, then:

    image

    :oP

    Sorry, I won't do it again... just (much like the muppet) I couldn't resist.
    drdavewatfordplasmodiumYellowcastle
  • gratefulnatgratefulnat SwitzerlandMember Posts: 262
    Huw,

    I've been trying since Saturday to access brickset, keep receiving error message 522: connection timed out (latest one: Ray ID faab9c75faf073d, whatever that means?).
    Just tried right now and no luck.
    Any ideas? (I've deleted cache, cookies, etc)

    Thanks
  • PaperballparkPaperballpark UKMember Posts: 3,379
    Huw said:

    Keep having to log in:

    This is causing a few headaches because it seems the cookie is present but is being ignored for some reason. I've made a configuration change this morning which might make a difference: let me know.

    Unfortunately it's not worked @Huw, I'm logged out again this morning.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    edited February 2014
    @gratefulnat, that was due to a problem with an attack on the CloudFlare network in Europe last night but it's OK now.

    @Paperballpark, I know :-(
  • BooTheMightyHamsterBooTheMightyHamster Northern edge of London, just before the dragons...Member Posts: 1,280
    AAAAAAAAAAAAAARRRRRRRRRRRRRRRGGGGGGGGGGGGHHHHHHHHHHH!!!!!!!!!!!

    STAY!
    LOGGED!
    IN!

    /lies down and pounds floor with fists

    Ok, just needed to get that off my chest. Carry on folks, nothing to see,
  • gratefulnatgratefulnat SwitzerlandMember Posts: 262
    Huw said:

    @gratefulnat, that was due to a problem with an attack on the CloudFlare network in Europe last night but it's OK now.

    Thanks for the info Huw.
    Today I'm finally able to access the site again (yesterday only got an offline version).
    Feels very good ;-)
  • AleyditaAleydita BelgiumMember Posts: 760
    The log in issue. Just thought I'd share something I noticed, it might just be me of course but while I'm at home, I only need to re-login to the main site if I've logged in on my mobile phone while out on the road. It had me wondering if it's an IP address issue, with it automatically closing active sessions which don't match the same location as the most recent login.
  • OldfanOldfan Chicagoland, IL, USAMember Posts: 612
    In general, I have to re-logon to the main Brickset site every morning, and I stay logged in all day. The next morning, I need to login again.

    I'm in Chicago area, USA. I have no issues with staying logged in to the forum.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    I may have a fix for this, which will be uploaded tomorrow morning.
    Paperballpark
  • psycho013psycho013 Member Posts: 8
    Not sure if this is the right place to post. If not, I apologize.
    Is there anything in the works for the Amazon deals page to retrieve only items sold and shipped by Amazon? Some of these prices from marketplace vendors end up well over retail when you include their inflated shipping.
  • ryan498ryan498 Member Posts: 37
    I cannot export any of my Sets or Minifigures as any of the available export formats. I keep getting a 404 Page not found error.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    ^^ The prices of the sets with > 25% discount have the postage factored in now.

    ^ Which pages do you get 404s on? It works for me...
  • rancorbaitrancorbait Manitoba CanadaMember Posts: 1,850
    @Huw Just noticed a little error as I was looking through my minifig collection, Aragorn has been named "Aragom" :o)
  • BumblepantsBumblepants Sofia BG/Dallas TXMember Posts: 5,552
    ^I think the 'r' and 'n' are just colliding.
  • ryan498ryan498 Member Posts: 37
    Huw said:

    ^^ The prices of the sets with > 25% discount have the postage factored in now.

    ^ Which pages do you get 404s on? It works for me...

    It was on this page when I click on export my owned sets either as any of the export options: http://brickset.com/export

    I have just check it now though and it seems to be working for me. Strange.
  • henrysunsethenrysunset Member Posts: 230
    My new topic on the forum has been stuck in limbo for over 24 hours. When I hit "submit" i see this message:

    "Your comment will appear after it is approved."

    I've never seen a delay in posting new topics before, what's going on?
  • ChanMcLChanMcL Member Posts: 1,224
    www.brickset.com/forum/ redirects me to http://www.bricksetforum.com/discussions/

    I don't know why. Tried it on Firefox and Chrome, same thing happens
  • PaperballparkPaperballpark UKMember Posts: 3,379
    ^ Same here. Odd, as it was working fine earlier this morning.
  • timinchicagotiminchicago USAMember Posts: 239
    ^ Also the same thing for me this morning.
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    edited February 2014
    I changed it from http://www.bricksetforum.com this morning. People (me included) prefer that landing page, apparently.

    On the old site you could choose which page to land on and have it saved in your profile but I haven't re-implemented that yet.
    drdavewatfordLegoboy
  • OldfanOldfan Chicagoland, IL, USAMember Posts: 612
    ^I was wondering why that keeps happening when I open to the forum...when you get a chance, could you re-implement the choice if you can? My 2 cents' worth; thanks.
  • masterX244masterX244 GermanyMember Posts: 431
    i prefer the category view, too so the setting has to come back (not interesting in the US deals or other stuff) appearing higher up; and im used to finding stuff at certain positions
    Paperballparkcheshirecatweevin
  • MatthewMatthew Cheshire, UKAdministrator Posts: 3,734
    edited March 2014
    If there are specific sections (eg: Shopping threads from other countries or the Marketplace) that you really don't want to ever see in discussions view then you can hide them by going to the 'All discussions' link in the right hand column and clicking hide (under the cog menu to the right of the category title).
  • masterX244masterX244 GermanyMember Posts: 431
    @matthew second reason is that my brain already expects certain threads like the Predictions on EOL sets or the current lego status at certain spots down the page so disabling categories and using a noncategory view invalidates that habits
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    OK, I'll see what I can do...
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    edited March 2014
    Update on the original issues:

    Sign-up and password reset emails not being received

    Resolved although it seems gmail often 'discards' the messages for some reason: most reports of then not being received now are from gmail users.

    Country detection

    Sorted

    Keep having to log in

    Sorted

    Adding/Editing comments

    Sorted

    Breadcrumbs on set details pages

    Still an issue

    Amazon price comparison page

    Features of the old site have been reinstated

    Import from Rebrickable and Lugnet

    Sorted


    Legoboyplasmodium
  • cheshirecatcheshirecat Member Posts: 5,332
    edited March 2014
    Nice to see all those fixes - but ack, can't stand the discussions view. Thankfully just clicking on 'Brickset Forum' title text sorts it out, but still a step backwards imo. Fairly sure we had a lengthy discussion on the discussion/category view back in the day and the category view was the overwhelming favourite.

    From a practical point of view having the two different styles as the default for the two different sites helps, from a design/usability point of view its totally backward.
    LegopantsOldfan
  • LegoboyLegoboy 100km furtherMember Posts: 8,691

    Nice to see all those fixes - but ack, can't stand the discussions view. Thankfully just clicking on 'Brickset Forum' title text sorts it out, but still a step backwards imo.

    And what is your step backwards is my step forwards. I no longer have to click the 'Discussions' tab. :o)
    MatthewmartynJosephiamterry
  • PaperballparkPaperballpark UKMember Posts: 3,379
    I have the forum bookmarked anyway.
  • drdavewatforddrdavewatford Hertfordshire, UKAdministrator Posts: 6,222
    edited March 2014
    Legoboy said:

    Nice to see all those fixes - but ack, can't stand the discussions view. Thankfully just clicking on 'Brickset Forum' title text sorts it out, but still a step backwards imo.

    And what is your step backwards is my step forwards. I no longer have to click the 'Discussions' tab. :o)
    Precisely - I want to quickly see what's new, if anything, not see the same old messages that I've already viewed at the top of the pile and have to scroll down to see if anything's changed. So I hate category view....
    scrumperBumblepantsLostInTranslation
  • masterX244masterX244 GermanyMember Posts: 431
    and thats why a setting on brickset.com can fix it :) cause most of us long time lurkers here have a brickset account so a setting can be made sticking to the account
  • timinchicagotiminchicago USAMember Posts: 239
    I have noticed that the "Visits" counter (at least for me) has not changed in several days.
  • scrumperscrumper UKMember Posts: 323
    @Huw I haven't checked many others but on the main site page for FB the new brickipedia link shows the description for part no. 10179 rather than #10197
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    edited March 2014
    ^ that's one of the issues that needs resolving still, how to differentiate pages.

    Also, I've noticed their server times out a lot of the time so I suspect Brickset is overloading it.
  • MeikoMeiko Member Posts: 11
    scrumper said:

    @Huw I haven't checked many others but on the main site page for FB the new brickipedia link shows the description for part no. 10179 rather than #10197

    The issue there is with the way Brickset gets it's data. We had to write a custom API for Brickset to use for the Brickipedia module on set pages, which can be found here. What the 'snippet' API action does is it retrieves a snippet of text from a Brickipedia search result. The reason it does this is because Brickipedia uses a different set number format than Brickipedia (Brickset does 10197-1, while Brickipedia just does 10197). It's the easiest way to make the content "compatible" between sites, but yes, there are some bugs. Now that you bring it up, it'll be really helpful if you can tell me any other Brickset set pages that show the wrong Brickipedia content, and then I'll see what I can do to get them sorted out. :)

    @Huw: That's odd. I haven't seen it time out yet today. Can you let me know what pages you're trying to access and whenever it has an issue for you? There may be related errors in our error logs that could help me fix this. Thanks. :)
  • legomattlegomatt Member Posts: 2,541
    I'm suddenly running into an issue when using the forum. Probably not a forum specific thing, but just how my system is reacting to it.

    If i type 'at' (not the words, but the 'circled-a' symbol) to reference a specific username, the forum interface (for want of a better word) produces a dropdown menu of options which immediately plays merry havoc with my browser/keyboard.

    Instead of being able to continue typing in the comment box, the keyboard just wants to issue browser commands, such as making the page backup, or scroll down, etc.

    As a tech-dullard I don't know how to tell my keyboard to cancel the change in its behaviour and get back to typing in the box.

    Anybody know what's happening, and how to correct it?
  • UnixpaceUnixpace Member Posts: 12
    ^ I think the problem is in your system as you said, @legomatt‌. This behaviour is actually a feature: you type @ and some characters and a dropdown menu appears to help you complete the username. I've just checked and it works for me using Firefox, Chrome, Opera and Explorer running Windows 7, and I remember using it before on Chrome/Linux too.

    I know it sounds like the typical helpdesk advice, but try updating your browser if it's not updated already.
  • legomattlegomatt Member Posts: 2,541
    edited March 2014
    Yeah, I could tell, just as you say, it was an auto-complete feature of some kind (I never noticed it before - was it recently added?), and that my system was reacting to it in a 'thrown into wrong gear' type way.
    We're using Safari. (Unfortunately, it's not my machine, so I'm loathe to alter any system settings in case I 'break' something).

    Is there a way I can turn off the auto-complete function, OR if not, does anybody know what the basic standard keyboard/mouse key (if there is one) to revert me back into 'normal' functioning mode again.
    I'm guessing some techy person here knows the reasons for a keyboard firing commands to a browser to do stuff (like it's a 'gear shift'), so I'm thinking/hoping there might be a simple 'reversal' button?
  • plasmodiumplasmodium UKMember Posts: 1,936
    A workaround would be to type the person's name, and then go back and add the "@" afterwards. I often have to do a similar sort of thing on my android phone whenever pop-ups come up in text boxes, as the keyboard will sometimes go away or do other funky things.
  • PaperballparkPaperballpark UKMember Posts: 3,379
    Maybe type your comment into a notepad-like programme, then copy and paste into the comment box?
  • legomattlegomatt Member Posts: 2,541
    edited March 2014
    ^^ @plasmodium Yep, typing the @ in after writing the whole post seems the simplest workaround to prevent keyboard-fits. :o)
  • ricecakericecake Maryland, USAMember Posts: 879
    I'm not sure if it's a problem on my end, but using Firefox 27.0.1 on Windows 7 64-bit, the Activity RSS feed keeps saying "Live Bookmark feed failed to load." The News feed and Amazon.com Bargain feed both load perfectly fine. What's weird is that when I navigate to the feed url at http://brickset.com/feed/activity , that loads and renders properly in the browser. It's only in my Bookmarks bar that I get the error.
  • plasmodiumplasmodium UKMember Posts: 1,936
    One I discovered today - just viewing the site on my phone (which I don't usually do) and I discovered I couldn't change region - I was stuck on US. When I clicked on the flag, no popup or anything came. Even trying "open in new tab" (which sometimes forces popups to work) didn't do anything. This is with Chrome (latest version) on Android 4.3.
  • legomattlegomatt Member Posts: 2,541
    edited March 2014
    This very moment, I'm getting a 'cloudflare always online' notification for the main site, which means i can browse the main site, but not update anything as it isn't 'live' (i guess). Anybody else finding the brickset main site 'down' right now, or is it just me?
  • legomattlegomatt Member Posts: 2,541
    Seems to be 'live' again now :o)
  • ricecakericecake Maryland, USAMember Posts: 879
    ricecake said:

    I'm not sure if it's a problem on my end, but using Firefox 27.0.1 on Windows 7 64-bit, the Activity RSS feed keeps saying "Live Bookmark feed failed to load."

    For what it's worth, the feed now loads properly for me. I am also on Firefox 28.0 now.
  • cmrt1014cmrt1014 Member Posts: 396
    I've been following the new inventories/instructions feeds. I'm not sure they're updating - the most recent are the 9th/14th of March - and based on the wonderful data graph Huw posted, they should have updated by now. There is a new inventory for 4000011 as noted in the forum. Not sure on the instructions.

    Also, the images for gear/sets 760 are a bit confused. The gear (760-1) is showing the set image (but states that it's a storage cabinet), as does the set (760-2).
  • HuwHuw Brickset Towers, Hampshire, UKAdministrator Posts: 6,357
    edited March 2014
    The inventories are pulled in on a Sunday morning, and 4000011 has just been found.

    I've removed the image for #760-1.
Sign In or Register to comment.
Recent discussions Categories Privacy Policy