Shopping at LEGO or Amazon?
Please use our links: LEGO.comAmazon
As an Amazon Associate we earn from qualifying purchases. site issues



  • Leowolf27Leowolf27 Member Posts: 1
    edited May 2017
    EDIT: As I finished typing I tried again and the issue seems to have been resolved. For anyone else still experiencing the problem, clear your temporary internet files.


    New to the forum, but please allow me to say the following:

    I've also had experienced this problem with the website loading without format or style. It seems that on request the files styles.css and template.css arrive complete, but with what appears to be either typos or logic errors right at the beginning of the file.

    To get the looks of the website back I edited the files using Chrome developer tools in the following way.

    For styles.css:

    body {
        width: 100%*zoom:1;
        body: after,body:before {
            display: table

        body: after {


    body {
        width: 100%;
        zoom: 1 }

    body::after,body::before {
        content: "";
        display: table

    body::after {
        clear: both
    And for the template.css:

    audio,canvas,video {
        display: inline-block*display:inline*zoom:1;
        audio: not([controls]) {
            height: 0


    audio,canvas,video {
        display: inline-block;
        zoom: 1

    audio: not([controls]) {
        display: none;
        height: 0

    Locally this change brings the looks of the Brickset website back to what I'm used to.

    I tested the problem (not the fix) on the following browsers:

    • Google Chrome 58.0.3029.110 (64-bit)
    • Mozilla Firefox 50.0.2
    • Apple Safari 5.1.7 (7534.57.2)
    • Opera 45.0.2552.635 (PGO)
  • HuwHuw Administrator Posts: 7,087
    That CSS hasn't changed since the new site launched in 2014. The *s are deliberate to fool some browsers. The CSS source (written by my designer) says:

     * Correct `inline-block` display not defined in IE 6/7/8/9 and Firefox 3.

    video {
        display: inline-block;
        *display: inline;
        *zoom: 1;

    So, I don't think that's the issue.
  • lentillentil Member Posts: 53
    OK, I have no idea what the problem was, but I cleared my internet cache and now everything is fine. thanks for the suggestion Leowolf27!
  • masterX244masterX244 Member Posts: 534

    lentil said:

    OK, I have no idea what the problem was, but I cleared my internet cache and now everything is fine. thanks for the suggestion Leowolf27!

    probably some bits getting messed up somewhere in your cache and then messing up the rest of the file.
  • ThoughtsonblocksThoughtsonblocks Member Posts: 178
    Clicking on those links just gives me a page full of code, anything specific I need to do to manually load it?  Still having the problem, curious that lentil has it too.  Any chance its a region specific thing?  Lentil and I are from the same general area.  Only takes me a few minutes and some bad decisions to end up in Wisconsin.  
  • ThoughtsonblocksThoughtsonblocks Member Posts: 178
    Just saw those posts about clearing the cache, thought I had tried that already but went through and did it on IE, cleared cache and did a full browser reset and that fixed the problem.  Did a more selective reset on chrome of "cached images and pages" and that fixed chrome.  Must have just picked up a bad set a few days ago and saved it.  odd it happened on 3 different browsers on 4 computers plus a cell phone.  
  • RecceRecce Member Posts: 923
    Just noticed that my minfigure count ranking is now using the number for loose minifigures instead of the number for all of my minifigures. Is this a bug?
  • HuwHuw Administrator Posts: 7,087
    Yes it looks like it. I'll investigate.
  • StattoCampoStattoCampo Member Posts: 2
    Possibly related to the above, I'm no longer seeing the minifigs tab for each set. Has this option been removed, or is it part of that issue?
  • HuwHuw Administrator Posts: 7,087
    It was, but it's now sorted.
  • RoobotRoobot Member Posts: 24
    When you touch one of the stars under "Your Rating" for a set, it instantly gives the set that rating.  The problem is it does that even while swiping on a mobile device.  It also usually stops or prevents the scroll action.

    So, for example, when I'm on my iPhone trying to quickly scroll through my Wanted List, I end up accidentally assigning sets ratings and/or having the scrolling stopped prematurely if my finger swipes on a star.

    Perhaps you can use a different event for this that doesn't fire when swiping?  I'm using Safari on iOS 10.3.2, for the record.

    Other than that, I have to really compliment you on Brickset's great responsive web design!
  • HuwHuw Administrator Posts: 7,087
    Thanks for your comments. 

    The behaviour you describe is a bit of a nuisance I agree. I'm not sure what if anything can be done but I'll look into it.
  • AleyditaAleydita Member Posts: 952
    Not a big thing but when browsing sets there are clickable links that allow you to skip to the next and previous sets in the database. Great, always nice sometimes just to have a browse. I noticed the same is true for the set list pages like...

    Problem here is that - for example - when you click the '1984' link, because there are no polybag sets in the database for 1984, it doesn't offer the '1983' and '1985' links on the 1984 page.
  • HuwHuw Administrator Posts: 7,087
    A known issue that's in the 'too difficult to fix' list at the moment!
  • snowhitiesnowhitie Member Posts: 3,078
    That rating thing that @roboot mentioned happens to me all the time, would be great if you could change something about that, I never look at the ratings just at the reviews since I assume this kind of thing happens to everyone. I'm on Android.
  • zmarkellazmarkella Member Posts: 48
    Has anybody got issues posting comments on articles? I noticed that sometimes I need to 'post' 2-3 times before the comment appears.

    With the first click the comment box is emptied, which is annoying, but now I know to ctrl-c the comment before hitting 'post'.
  • MaffyDMaffyD Member Posts: 3,527
    ^ Yeah, happens to me. Thought it was my browser. Obviously not.
  • zmarkellazmarkella Member Posts: 48
    ^ seems to be working fine now - not sure if anything has changed
  • catwranglercatwrangler Member Posts: 1,894
    It's been going on for a long time. Did you hit refresh before posting successfully? That usually works for me, but like yourself, I tend to copy the comment before posting these days, just in case...
  • BumblepantsBumblepants Member Posts: 7,624
    Seems to happen to me if I try to post while Vanilla forums is saving a draft.
  • PinoPino Member Posts: 5
    Huw said:
    I should work on serving it via https but I'm not sure how to. I think it can be done via CloudFlare but I've not investigated fully.

    I'll make a point of doing so shortly.
    I finally also updated the Chrome extension BrickTip. Also added a search set feature to it while I was at it. But the https api works like a charm!
  • Addicted2OxygenAddicted2Oxygen Member Posts: 467
    There is a bug in the CSV export. A comma is missing after the ImageURL entries concatenating ImageURL and OwnedBy.

    <span style="background-color: transparent; color: inherit; font-size: inherit; font-family: "lucida grande", "Lucida Sans Unicode", tahoma, sans-serif;">10240,"21103","1","Ideas","Licensed","2013","The DeLorean Time Machine",2,401,34.99,34.99,44.99,39.99,"</span><b style="background-color: transparent; color: inherit; font-size: inherit; font-family: "lucida grande", "Lucida Sans Unicode", tahoma, sans-serif;">jpg"10938</b><span style="background-color: transparent; color: inherit; font-size: inherit; font-family: "lucida grande", "Lucida Sans Unicode", tahoma, sans-serif;">,2727,"Yes","No",1,4</span></div>

  • HuwHuw Administrator Posts: 7,087
    Not any more...
  • FowlerBricksFowlerBricks Member Posts: 1,731
    The 3D views of sets won't show up.
  • Lego_StarLego_Star Member Posts: 2,144
    Now, it might just be my wonky internet (mast overcapacity) but the main site is not showing my set info on the main page after some time. I logged out and back in again, and after sometime the whirring circle next to my username is still whirring around and still no set count, fig count in the top right.

    Whilst I was hoping it would sort itself I tried to click "like" on an article. It just jumped me to the top of the page. I tried this a few times, same result.

    Looked at my wanted sets, went to update some to have - tick appears in the box, but not registering the update, no green box.

    Lastly I chose to narrow down the view of my wanted sets, choosing to show just the advanced models. Didn't show the results of the filter.

    Using ipad mini with latest version of safari. At this time though, browsing usually isn't an issue.
    Is anyone else experiencing the same? This is a new problem for me.
  • MattDawsonMattDawson Member Posts: 1,486
    No issue for me on a Samsung S7 and chrome, so probably a network issue, unless the data has gone faulty...
  • HuwHuw Administrator Posts: 7,087
    No problems here as far as I'm aware.

  • Lego_StarLego_Star Member Posts: 2,144
    Whatever was wrong last night is no longer a problem. All the information there just now and behaviour of clicks, updates and filters as expected once more both on the main page and within the database.
  • drdesignzdrdesignz Member Posts: 110
    The home page is showing giant awful advertising today on one of my computers, but not on the other one.  I figured it was a virus, despite not having one in many years.  But a couple scans doesn't show any results.  I'm confused.  Is the home page supposed to be full of advertising?  Not the Amazon, eBay, [email protected] stuff.  All that's fine.  This is garbage malware-like ads.
  • dmcc0dmcc0 Member Posts: 778
    ^ Sure you are logged in?  I occasionally get logged out if I haven't accessed the site on a particular machine for a while and am sure the ads only show if you are not logged in.
  • drdesignzdrdesignz Member Posts: 110
    Well, I logged in and they're gone now.  I gotta be honest, it's quite terrible.  If I saw this on my first visit here, I'd quickly close the tab and possibly never return.  
  • HumdrumHumdrum Member Posts: 71
    drdesignz said:
    Well, I logged in and they're gone now.  I gotta be honest, it's quite terrible.  If I saw this on my first visit here, I'd quickly close the tab and possibly never return.  
    I had the same issue today, I tried blocking those adds with uBlock to no avail. They kept reappearing.
  • PaperballparkPaperballpark Member Posts: 4,268
    ^ Just log in...
  • Patrik78Patrik78 Member Posts: 142

    Guys, is there any way how to display sets in your collection using a more compact view as a "List"? I can remember some time ago my collection was displayed as several sets visible on the screen at once with all the detail to the right, now there's one and half set visible because the image is three times bigger and so is the info table.

    Unfortunately I don't posses a screen of the previou display format.

    Thanks for your help.

  • HuwHuw Administrator Posts: 7,087
    Gallery view?
  • Patrik78Patrik78 Member Posts: 142
    edited September 2017
    Thanks for the answer Huw, but it's not that. I think it was a normal "List" view in a more compact form. The set information (price, details, wanted, owned) - all was displayed to the right (with a black background I think) with only one set per line. Also the picture of the set was much smaller. It changed two weeks ago to the current view and I cannot get back to the old one. Strange.
  • HuwHuw Administrator Posts: 7,087
    OK, that's probably the old retired and now unsupported list view that hidden from the UI. I've re-enabled it for you but bear in mind it won't be updated with the latest features and may not continue to work in future.
  • Patrik78Patrik78 Member Posts: 142
    Thanks a lot Huw!
  • Brickset has been a great place for me to keep track of my collection, and I thank the developers for the work they are doing. I have two suggestions that may make adding set details easier. First, allow copying an entire ACM entry, similar to the duplicate function, but allow pasting the entry into a different set. This would allow faster entry when entering a number of sets that were acquired on the same day or from the same vendor, such as an entire Minifig series. Second, when using the ACM entry form on my phone, the entire form is not visible, and I cannot scroll to hit the "edit" button. It would be helpful if the form were to automatically reformat based on the screen's dimensions. 
  • MaffyDMaffyD Member Posts: 3,527

    This probably isn't an issue per se, but I'm just wondering if the code for the Site Updates side bar on the home page has been changed recently? There looks to be dates on them now which weren't there before (unless I was up to now very unobservant) which I absolutely love, and the set names on the 'sets' and 'shop' options seem to be bigger, with maybe too much being shown with them. Any ideas, or is it just me?

  • HuwHuw Administrator Posts: 7,087
    @ArkansasBricker, work in enhancing the ACM, particularly using it on mobiles, is long overdue! I hope to attend to it over the winter once the LEGO show/holiday season is over.

    @MaffyD, I think it's you. I see dates, right aligned.
  • PeteMPeteM Member Posts: 447
    @ArkansasBricker A workaround for the ACM issue is to scroll to the bottom of the set page and select 'Switch to desktop view'. You can then open, zoom, and move around the ACM pop up window as required (at least, you can on Safari on iPhone) Not perfect, but it works :)
  • MaffyDMaffyD Member Posts: 3,527
    @Huw - thanks for the reply. It's changed since, and now shows dates aligned to the right like you say, and has none of the 'previous', 'next' and theme and set information under the set image that it used to. Looks good! I doubt my browser would go off to Brickset and grab that detail just to show on your homepage, so it was definitely server-side. :-)
  • JBricks27JBricks27 Member Posts: 678

    Can these sidebar ads get removed? Even if I close the ad, the bar remains, rendering the page useless... 
  • HuwHuw Administrator Posts: 7,087
    Log in and you won't be troubled by ads.
  • LobotLobot Member Posts: 1,029
    edited October 2017
    @Huw - My laptop is really struggling to load the new layout with all of the new ads, and it's getting to the point where I can't even sign in!  Please can you have a re-think about it?  I appreciate you want to optimise your revenue, but it's become far too invasive for a bit of light browsing.
  • Pumpkin_3CK5Pumpkin_3CK5 Member Posts: 805
    edited October 2017
    I'm trying to make an account, but when I click on sign up, all I get is:

    The page you are looking for cannot be found.

    Similar results are provided below, or you can try another search

  • HuwHuw Administrator Posts: 7,087
    ^ I had to remove the signup page over the weekend as a robot created some 100,000 accounts in the space of a few hours just before I went to Swindon.

    I'll be reinstating the page tomorrow  and in the meantime you can sign up using the form on the home page side bar.
  • AstrobricksAstrobricks Member Posts: 5,478
    Not sure how long this has been broken, but I just noticed that my minifig collection suddenly shrank from 500+ to 25. My sets collection seems to be the right size (374). What happened? Aren't minifigs in sets still counted?
  • OdeinoichusOdeinoichus Member Posts: 361
    It seems that the Minifigure count has lost all data for those found in sets. Only the loose minifigs are being counted. What happened? All Minifigures found in sets have just vanished from the counts. Did somebody input an improper code or something?
Sign In or Register to comment.

Shopping at or Amazon?

Please use our links: Amazon

Recent discussions Categories Privacy Policy

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started. is a participant in the Amazon Services LLC Associates Program, the, Inc. Associates Program and the Amazon EU Associates Programme, which are affiliate advertising programs designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.

As an Amazon Associate we earn from qualifying purchases.